Tiger Sport 1050 Forum

Please login or register.

News: Why not add an avatar to your profile ?



Author [ES] [MY] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: Unknown HID Install - Flash/ Dip Beam button not working  (Read 779 times)

0 Members and 1 Guest are viewing this topic.

Offline Megaross

  • Tiger Pro
  • ***
  • Posts: 124
  • Bike/Model: Tiger 1050 '07
  • City / Town: Swindon
  • Country: UK
Unknown HID Install - Flash/ Dip Beam button not working
« on: 17 January, 2019, 09:13:45 AM »
As per the title really, there's a nondescript HID install on my bike the previous owner did. Not really sure what kit he used.

I recently replaced both the relays as one was flickering and going out at random but I've just noticed that the flash/ drop beam button doesn't work. Is there any reason for this, possibly I have used the wrong ballasts? Possibly the previous owner was a hack and did a crappy install?

Not sure how to go about troubleshooting this one as I really don't know much about HID lights.

Offline Sidewinder

  • Tiger Master
  • ****
  • Posts: 471
  • Bike/Model: 2007 Tiger 1050 Yellow
  • City / Town: Sheffield
  • Country: UK
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #1 on: 17 January, 2019, 11:54:12 AM »
Has he installed just the HID bulbs in the original projectors or put new projectors + HID in?  Do you have low beam one side and high the other?  Take a pic of the hi/lo beam patterns on a wall, the headlight unit looking at the front (lights off) and the rear of the unit with covers removed.

Offline Megaross

  • Tiger Pro
  • ***
  • Posts: 124
  • Bike/Model: Tiger 1050 '07
  • City / Town: Swindon
  • Country: UK
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #2 on: 17 January, 2019, 05:59:45 PM »
Cheers sidewinder, I'll get some pics tomorrow.

Offline Dusty ST

  • Tiger Supporter
  • Tiger Master
  • *
  • Posts: 268
  • Bike/Model: 2017 Tiger Sport 1050
  • City / Town: Brighton, Sussex
  • Country: United Kingdom
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #3 on: 18 January, 2019, 02:10:28 PM »
HIDs don't really work too well for a flash function as they take a couple of seconds to warm up, I'm assuming an '07 Tiger uses H7 bulbs.
On my Sprint it's easier as it has three lights, I have 2 HIDs for dip beam and a normal H7 bulb for high beam/flash.
17 Tiger Sport 1050
08 Sprint 1050ST
01 GSX1400 K2

Offline Timbox

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 3355
  • Bike/Model: Helga
  • City / Town: Newport
  • Country: United Kingdom
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #4 on: 18 January, 2019, 03:31:01 PM »
*Originally Posted by Dusty ST [+]
HIDs don't really work too well for a flash function as they take a couple of seconds to warm up, I'm assuming an '07 Tiger uses H7 bulbs.
On my Sprint it's easier as it has three lights, I have 2 HIDs for dip beam and a normal H7 bulb for high beam/flash.

Think its 1 H7, and 1 H9
Ex Sport owner now on KTM 1290 SAS

Offline Yellow Dog

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 9650
  • City / Town: AUCKLAND
  • Country: New Zealand
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #5 on: 18 January, 2019, 07:23:37 PM »
*Originally Posted by Dusty ST [+]
HIDs don't really work too well for a flash function as they take a couple of seconds to warm up, I'm assuming an '07 Tiger uses H7 bulbs.
On my Sprint it's easier as it has three lights, I have 2 HIDs for dip beam and a normal H7 bulb for high beam/flash.

If you are holding the flashed button down for a length of time and the lights don't illuminate, those buttons do fail, regardless as to the HID kit. If you take it apart and re-heat the dry solder, that fixed mine for me.
2018 TIGER 1050 SPORT (c8

Offline Megaross

  • Tiger Pro
  • ***
  • Posts: 124
  • Bike/Model: Tiger 1050 '07
  • City / Town: Swindon
  • Country: UK
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #6 on: 21 January, 2019, 03:11:02 PM »
Hey guys, got a few pics today sorry it took so long

https://imgur.com/a/ku9sfQo


Offline Megaross

  • Tiger Pro
  • ***
  • Posts: 124
  • Bike/Model: Tiger 1050 '07
  • City / Town: Swindon
  • Country: UK
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #7 on: 12 February, 2019, 07:48:15 AM »
Right, given up with the crappy flickering. I think I'm going to rip out this lot and start from scratch.

Is there any recommendation for HID upgrades on the tiger 1050 for decent quality parts? A lot of these eBay sellers I'm unsure of, lots of super chinese junk out there after all.

Offline DaveH

  • Tiger Pro
  • ***
  • Posts: 203
  • Bike/Model: Tiger 1050 Sport
  • City / Town: Belper
  • Country: UK
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #8 on: 12 February, 2019, 08:41:31 AM »
If you're going to spend money, I'd go for a set of Tiger Sport lights with proper reflectors... Hid is a bit passe these days with the advent of LEDs.... Then there's the delay in swapping over beams while they warm up etc...
As for the h/l flash button, check it's wired up... Ive disconnected mine to use as a push to talk button on my bike to bike radio.... If I need to flash the lights I just cycle the hi/lo switch...
Tiger 1050 Sport :001:
Honda VFR800 VTEC :152:
Moto Morini Corsaro 1200 :037:

Offline Timbox

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 3355
  • Bike/Model: Helga
  • City / Town: Newport
  • Country: United Kingdom
Re: Unknown HID Install - Flash/ Dip Beam button not working
« Reply #9 on: 12 February, 2019, 08:51:17 AM »
As said above, but if you must go HID, these people have always had a good name for decent kit:

https://www.hid50.com/
Ex Sport owner now on KTM 1290 SAS