Tiger Sport 1050 Forum

Please login or register.

News: Why not add an avatar to your profile ?


Author [ES] [MY] [PL] [PT] [IT] [DE] [FR] [NL] [DK] [NO] [GR] [TR] Topic: No neutral light so bike not start?  (Read 709 times)

0 Members and 1 Guest are viewing this topic.

Offline Tigermike

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 1042
  • Bike/Model: 2010 Bk/Grey 1050SE
  • City / Town: Banbury
  • Country: United Kingdom
No neutral light so bike not start?
« on: 29 December, 2018, 02:03:21 PM »
My bike has been sat in the garage since last Friday on its centre stand
Got it out and washed it this morning as it was filthy, gave the chain a clean and relube and did some other maintenance.
Went to turn it on to warm up to check oil levels but no neutral light  :187:
Obviously no neutral light , the fuel pump doesn't prime.
Bike deffo not in gear so sprayed contact cleaner in handlebar clutch switch and side stand switch and pumped it several times.., but no luck  :232:
Can it be anything other than those 2?
Need to get it sorted before Wednesday when its back to work  :148:
« Last Edit: 29 December, 2018, 02:05:39 PM by Tigermike »
Yam RD125 DX, Kwak GPZ305, Honda CB400T, 1983 Kwak GT550, Suzuki GSF650 Bandit, Tiger 1050SE .... got there in the end.

Offline Tigermike

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 1042
  • Bike/Model: 2010 Bk/Grey 1050SE
  • City / Town: Banbury
  • Country: United Kingdom
Re: No neutral light so bike not start?
« Reply #1 on: 29 December, 2018, 02:31:37 PM »
Don't worry folks ..all ok knobhead here just had a thought.. Wonder if I knocked the kill switch off ...  :164:
Yes I did .. What a pillock thank god that's all it was  :462:
Yam RD125 DX, Kwak GPZ305, Honda CB400T, 1983 Kwak GT550, Suzuki GSF650 Bandit, Tiger 1050SE .... got there in the end.

Online Timbox

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 3038
  • Bike/Model: 2016 TS Matt Black
  • City / Town: Newport
  • Country: United Kingdom
Re: No neutral light so bike not start?
« Reply #2 on: 29 December, 2018, 03:15:02 PM »
*Originally Posted by Tigermike [+]
Don't worry folks ..all ok knobhead here just had a thought.. Wonder if I knocked the kill switch off ...  :164:
Yes I did .. What a pillock thank god that's all it was  :462:

Ha ha, never done it myself.......... :034:
2016 Tiger Sport, Power Commander, DNA, Wilbers Suspension, Healtech Q/S

Offline Paullie

  • Tiger God
  • *****
  • Posts: 4213
  • Bike/Model: Tiger Sport (2014)
  • Country: UK/Belgium
Re: No neutral light so bike not start?
« Reply #3 on: 29 December, 2018, 10:17:08 PM »
Me neither. Never made that mistake in me life .....  :164:

Offline Tigermike

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 1042
  • Bike/Model: 2010 Bk/Grey 1050SE
  • City / Town: Banbury
  • Country: United Kingdom
Re: No neutral light so bike not start?
« Reply #4 on: 29 December, 2018, 10:35:11 PM »
 :008:  :008: you think it would Be the 1st I would check since I accidentally knocked the kill switch once before on the tiger and once on my previous bike .. Doh!  :138:
Yam RD125 DX, Kwak GPZ305, Honda CB400T, 1983 Kwak GT550, Suzuki GSF650 Bandit, Tiger 1050SE .... got there in the end.

Online ZuluTiger

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 2153
  • Bike/Model: 1050, KTM 1190 Adv.
  • City / Town: Suwanee
  • Country: USA
Re: No neutral light so bike not start?
« Reply #5 on: 30 December, 2018, 05:14:18 AM »
I've never noticed that the kill switch stops the neutral light from burning? Wonder what that logic is? Seems to be a trifle obscure in terms of an outcome. I'm off to check my KTM ...

Online Yellow Dog

  • Tiger God
  • *****
  • Posts: 9356
  • City / Town: AUCKLAND
  • Country: New Zealand
Re: No neutral light so bike not start?
« Reply #6 on: 30 December, 2018, 08:25:22 AM »
*Originally Posted by ZuluTiger [+]
I've never noticed that the kill switch stops the neutral light from burning? Wonder what that logic is? Seems to be a trifle obscure in terms of an outcome. I'm off to check my KTM ...

The kill switch kills the ECU completely, so all controlled functions are disabled.

It always worries me, when I am using cruise control and take my hand off the grip. Hitting the kill switch might not end well  :159:
2018 TIGER 1050 SPORT (c8

Offline seangee

  • Tiger Supporter
  • Tiger God
  • *
  • Posts: 2113
  • Bike/Model: 2016 Tiger Sport
  • City / Town: Bracknell
  • Country: United Kingdom
Re: No neutral light so bike not start?
« Reply #7 on: 30 December, 2018, 10:08:25 AM »
*Originally Posted by Yellow Dog [+]
The kill switch kills the ECU completely, so all controlled functions are disabled.

It always worries me, when I am using cruise control and take my hand off the grip. Hitting the kill switch might not end well  :159:
Did it once when trying bar muffs for winter. Just like a complete loss of power. Clutch in and across to the hard shoulder. Scary that the indicators won't work. I know I hit the hazard switch but can't remember if they came on or not.

YD just you wait. Those CC switches are awfully close to the kill switch once you start wearing proper winter gloves  :007:
Nothing is foolproof to a sufficiently talented fool.

Offline peejayess

  • Tiger Member
  • **
  • Posts: 66
  • Bike/Model: 2014 1050 Sport
  • City / Town: Cheltenham
  • Country: UK
Re: No neutral light so bike not start?
« Reply #8 on: 30 December, 2018, 03:00:44 PM »
Happy it was so simple. Had the same thing on a R1200, turned out to be a dodgy gear sensor switch. Could twiddle the gear lever to get it right, but changed out the sensor to be safe.

Offline Grouchybastard

  • Tiger Supporter
  • Tiger Member
  • *
  • Posts: 83
  • Bike/Model: 2010 Tiger 1050
  • City / Town: Buckheaven Orygun
  • Country: USA
Re: No neutral light so bike not start?
« Reply #9 on: 31 December, 2018, 03:59:51 AM »
*Originally Posted by Timbox [+]
Ha ha, never done it myself.......... :034:

and never at a stoplight downtown.  :157: